Dodo Problem - Anyone else?

Discuss Spyderco's products and history.
iamhoss
Member
Posts: 15
Joined: Fri Sep 24, 2004 10:33 am
Location: LA (Lower Alabama) USA

Dodo Problem - Anyone else?

Postby iamhoss » Tue Aug 03, 2004 12:00 am

Hi guys, first post. I have many Spydies but my favorite is my Dodo, when its working right. It's already been back to Spyderco once and I'm sending it back again tomorrow for the same problem. The shaft beneath the ball bearing that locks the blade keeps sticking and hanging up. It gets so bad sometimes that I can't pull it back to close the knife at all, just have to play with it. Also makes it extremely rough to open. The severity of the problem varies from one use to the next. The knife has seen VERY casual use and has not been worked hard nor abused. I'd like to think its isolated but, anyone else have this problem?

User avatar
markg
Member
Posts: 2144
Joined: Fri Sep 24, 2004 10:33 am
Location: Ohio

Postby markg » Tue Aug 03, 2004 11:12 pm

Both my DoDo and D'Allara work fine. Have not had a problem with either locking up, or the lock being difficult

Edited by - markg on 8/3/2004 11:14:02 PM

User avatar
Joyce Laituri
Member
Posts: 903
Joined: Fri Sep 24, 2004 1:00 pm
Location: Golden, CO USA

Postby Joyce Laituri » Wed Aug 04, 2004 8:30 am

iamhoss,

Welcome to the Spyderco forum. My apologies you are experiencing problems with your Dodo. Definitely send it back to us here at Spyderco.

Spyderco Warranty and Repair
820 Spyderco Way
Golden, CO 80403

1-800-525-7770 X255
303-279-8383 X255

iamhoss
Member
Posts: 15
Joined: Fri Sep 24, 2004 10:33 am
Location: LA (Lower Alabama) USA

Postby iamhoss » Wed Aug 04, 2004 11:18 am

Thanks Joyce. I'm sending it back today and your quick attention to my post is indicative of the service I have always received from Spyderco folks.

Since initially posting, I have read that there were some problems similar to mine with the "first production run" models but I'm not sure whether I have one of those. Just testing the waters to see if the problem is widespread.

I'm sure that the second return is certainly not due to a lack of commitment. I have them all but CHOOSE to carry a Spydie!

iamhoss
Member
Posts: 15
Joined: Fri Sep 24, 2004 10:33 am
Location: LA (Lower Alabama) USA

Postby iamhoss » Wed Aug 04, 2004 11:18 am

Thanks Joyce. I'm sending it back today and your quick attention to my post is indicative of the service I have always received from Spyderco folks.

Since initially posting, I have read that there were some problems similar to mine with the "first production run" models but I'm not sure whether I have one of those. Just testing the waters to see if the problem is widespread.

I'm sure that the second return is certainly not due to a lack of commitment. I have them all but CHOOSE to carry a Spydie!


Return to “Spyderco General Discussion”

Who is online

Users browsing this forum: Accutron, Bing [Bot], Burton Knut, DigDug72, Google [Bot], JMM, Marulaghost, Molle Ninja, MSN [Bot], Notsurewhy, Tabo, timlara, Wartstein and 23 guests